首页   >   代码编程

Maven打包失败,提示“找不到符号”

使用maven打包失败,一直提示“找不到符号”,但是使用idea对项目进行编译的时候是可以通过的,说明并没有缺失符号,而且更神奇的是,项目可以成功启动,完了之后访问也是正常的,就是打包不成功。

Maven打包失败,提示“找不到符号”

具体错误提示见上图,实体类article中的setTest方法找不到,这个字段是我今天加的,以前是没有的,莫非test还成了一个特殊字段了?抱着好玩的心理,改了一个名字之后发现,不管什么字段都不行,只要是这次新加的,都会导致打包失败,后来又换了一个实体类做测试,发现也一样不行。

因为项目中使用了lombok,所以怀疑到了它头上,以为是它在编译的时候么有自动生成get、set方法,对比其他项目,发现确实没有在maven的compiler插件中指定,以为找到了问题所在,赶紧加入配置测试了一波

<build>
    <plugins>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <configuration>
                <annotationProcessorPaths>
                    <path>
                        <groupId>org.projectlombok</groupId>
                        <artifactId>lombok</artifactId>
                        <version>1.16.6</version>
                    </path>
                </annotationProcessorPaths>
            </configuration>
        </plugin>
    </plugins>
</build>

问题依旧,这是还一直以为是编译的问题,所以觉着lombok搞不定就不用它了,直接手动写了一个get、set方法做测试

Maven打包失败,提示“找不到符号”

没想到还是不行,打包还是不行,排除了lombok的嫌疑,说明不是它导致的问题。

回想起上次碰到公司项目的一个线上问题:

在本地deploy了jar包到服务器私服中,但是在Jenkins中构建项目的时候,一直提示找不到那个包里面的内容,后来猜测是由于maven的缓存所致,将服务器仓库中对应的jar包给删掉之后重新deploy,问题还是没有解决,最后改了一个版本号,再次deploy之后,问题解决了!!!

我也果断跑去本地仓库中将之前install的包给删了,如下图:

Maven打包失败,提示“找不到符号”

将整个项目的目录给删了之后,再次install时就成功了,这两次问题的出现都是由于maven的缓存所致,是时候抽个时间好好了解一下maven缓存这块儿的知识点了~

QQ群: 686430774  /  718410762

站长Q: 1347384268

如果文章有帮到你,可以考虑请博主喝杯咖啡!

分享到:

欢迎分享本文,转载请注明出处!

作者:不忘初心

发布时间:2019-04-26

永久地址:https://www.jiweichengzhu.com/article/aaa381863d6b41f9b21ab9a28a0cf619

评论